Flexera One - IT Asset management - NAM - batch processing task delays

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One - IT Asset management - NAM - batch processing tasks delays

Timeframe: November 28, 2025, 9:31 PM PST to December 1, 2025, 9:12 PM PST

Incident Summary

On Friday, November 28, 2025, at 9:31 PM PST, our teams identified an issue affecting batch processing tasks for IT Asset Management (ITAM) in the NAM region, impacting a subset of our customers. Although the Flexera One platform remained accessible, the affected customers experienced delays and failures in batch processing tasks, along with related error messages.

The disruption primarily impacted batch processing tasks, and license reconciliation workflows, resulting in tasks being stuck in an “In Process” state for an extended period.

Upon investigation, our teams determined that the root cause was database storage exhaustion in the NA production environment. While clearing stuck jobs provided temporary relief, newly submitted jobs continued to face the same database constraints and failure patterns. To address this, we expanded the database storage capacity and implemented additional measures to clear the backlog and expedite inventory processing.

By December 1, 2025, at 9:12 PM PST, all services had returned to normal. The technical teams confirmed that job execution was proceeding without issues, and no new stalls were observed. The incident was officially declared resolved at that time.

Root Cause

 

The investigation revealed that the issue stemmed from database storage exhaustion in the North America production environment. A critical internal function, intended to eliminate obsolete data, encountered a failure during execution due to a software bug. Consequently, database operations began to experience primary key conflicts and deadlock situations during inventory and reconciliation processing. These conflicts resulted in tasks repeatedly retrying without making progress, particularly when processing reached the license reconciliation stage.

Remediation Actions

 

·        Database Storage Expansion- Expanded database storage capacity in the NA production environment to relieve immediate storage constraints.

·        Batch Processor Workload Rebalancing- Paused processing on older batch processor instances to allow stalled tasks to clear from the system.

·        Deployment of New Batch Processor Instances- New batch processor instances were started to take over workload processing.

·        Active Queue and Processing Monitoring- Actively monitored job queues and processing behavior to confirm forward progress.

·        Bug tracking- Logged the cleanup-function bug for further investigation and fix development.

Future Preventative Measures

 

·        Stabilization of Data Cleanup Mechanisms - A permanent fix will be implemented for the identified bug to ensure it operates reliably under high system load or low database storage conditions.

·        Database Monitoring review - Enhanced monitoring and alerting will be reviewed and implemented for database storage utilization, with clearly defined thresholds and escalation paths. This will enable earlier detection of capacity risks and allow corrective action to be taken before storage exhaustion impacts production workloads.

Posted Dec 16, 2025 - 10:41 PST

Resolved

After extended monitoring, our teams have confirmed that services are fully restored. Inventory processing has returned to normal, and the backlog has been completely cleared
Posted Dec 01, 2025 - 21:16 PST

Update

Processing activity continues to improve following the recent database capacity increase. The remaining delayed inventory tasks are moving through the system, and recovery is progressing as expected. Some customers may notice slower than normal response times in areas that load larger datasets, and this is expected to ease as the remaining processing completes.

We are monitoring progress closely and will provide further updates as recovery continues.
Posted Dec 01, 2025 - 09:21 PST

Monitoring

Our teams have completed a storage capacity increase and applied additional adjustments to improve processing for the affected customers. Processing activity is now moving through the queue, and we are monitoring progression to confirm that all workflows are running as expected. We will provide another update once validation is complete.
Posted Nov 30, 2025 - 16:33 PST

Update

Our teams have identified a storage-related condition as a potential contributing factor and are expanding capacity as part of the ongoing work to address the delays affecting inventory processing. We are monitoring processing activity as this change is applied and will share further updates as we validate its impact.
Posted Nov 30, 2025 - 14:41 PST

Update

Our teams remain focused on reviewing the inventory processing workflow for affected NAM customers, working to pinpoint the source of the slowdown and verify conditions impacting scheduled activities and reconciliation. Monitoring continues, and engineering teams are actively collaborating on resolution efforts. We will provide additional updates as new details emerge.
Posted Nov 30, 2025 - 02:07 PST

Update

Our teams are continuing to review the workflow steps involved in inventory processing for customers in the NAM region. Interim measures are being applied to keep affected processing activity moving while deeper analysis continues. Validation work is underway to narrow down where processing behavior is slowing and to confirm the conditions affecting related scheduled activities. Monitoring remains active across the impacted customers as this work progresses.
Posted Nov 29, 2025 - 17:08 PST

Update

Our teams are reviewing the specific stages involved in inventory processing to pinpoint the source of the delays observed by affected customers in the NAM region. Activity across impacted environments continues to be monitored closely while this analysis is underway.

Further updates will be shared as soon as we have additional findings or observable changes in processing behavior.
Posted Nov 29, 2025 - 06:48 PST

Investigating

Incident Description: We are currently investigating an issue affecting inventory uploads for IT Asset Management in the NAM region. The impact is limited to a subset of our customers, and while the platform remains accessible, those affected may experience delays or failures in inventory data processing, along with related error messages. Reconciliation processes may also be impacted for these customers.

Priority: P2

Restoration Activity: Our technical teams are actively engaged in investigating the inventory processing delays. Further updates will be provided as we continue to address the issue.
Posted Nov 28, 2025 - 22:25 PST
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Inventory Upload).