Flexera - Ticketing service - Degraded performance for email updates

Incident Report for Flexera System Status Dashboard

Update

Our teams continue to work toward a resolution. During the ongoing investigation, we identified that in some instances emails from Flexera may be being blocked by SharePoint. Addressing this issue requires additional investigation and coordination with the relevant parties to ensure the appropriate corrective actions are taken. We will continue to provide updates as more information becomes available.
Posted Aug 08, 2026 - 03:48 PDT

Identified

Our teams have identified the cause of the issue and are currently working to resolve it.
Posted Aug 07, 2026 - 05:28 PDT

Investigating

Issue Description: Our teams have identified that some Flexera customers' email systems are rejecting emails sent containing notifications of updates on Flexera Support cases.


Priority: P3

Restoration Activity:
Technical teams are actively investigating the issue.
In the meantime, please login to the Flexera Community and use the Support Case portal at https://community.flexera.com/s/case/Case/Default to review case status and check for any updates.
Posted Aug 06, 2026 - 21:55 PDT