Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 03, 2025 - 01:00 PDT
Scheduled
Flexera will be performing scheduled platform maintenance on the Snow Atlas production environment in the East US region. This update supports infrastructure improvements and may result in temporary unavailability of services for up to 4 hours during the window below. During this time, write operations will be unavailable and data updates will be paused.
Maintenance Window: PDT: August 3rd, 1:00 AM to 5:00 AM EST: August 3rd, 4:00 AM to 8:00 AM CEST: August 3rd, 10:00 AM to 2:00 PM UTC: August 3rd, 8:00 AM to 12:00 PM IST: August 3rd, 1:30 PM to 5:30 PM AEST: August 3rd, 6:00 PM to 10:00 PM BST: August 3rd, 9:00 AM to 1:00 PM
This scheduled maintenance affected: Snow Atlas SaaS Management (Snow Atlas - East US, Snow Atlas API – East US)
Posted Jul 29, 2025 - 05:36 PDT
This scheduled maintenance affected: Snow Atlas (Snow Atlas - America, Snow Atlas API - America).