Software Vulnerability Research – Service Disruption

Incident Report for Flexera System Status Dashboard

Resolved

The SVR platform has remained stable across both the web application and automated access during the extended monitoring period. No further issues have been observed, and technical teams have confirmed that all services are functioning as expected. This incident has been resolved.
Posted Mar 28, 2025 - 03:29 PDT

Monitoring

The redeployment of the application has been completed. Initial sanity checks have passed, and the platform is currently functioning as expected. The incident has now moved into the monitoring phase to ensure continued stability across both the web application and automated access.
Posted Mar 28, 2025 - 02:59 PDT

Update

We are currently redeploying the Software Vulnerability Research (SVR) application to address ongoing service instability. As part of this process, a brief interruption is expected across the platform, affecting both the user interface and automated access to vulnerability data.

Our teams are actively working to restore full functionality and are closely monitoring system behavior during this transition. We will provide further updates as progress continues.
Posted Mar 28, 2025 - 02:46 PDT

Investigating

The API servers became unresponsive again after being reintroduced, and the issue has resurfaced. In addition, the SVR web application is now experiencing degraded performance.

We are actively investigating both the recurrence of the automated access issue and the new impact to the application. Monitoring and diagnostics are ongoing.
Posted Mar 28, 2025 - 02:27 PDT

Monitoring

The services supporting automated access to vulnerability data have been brought back online and are now responding as expected. Users are able to authenticate successfully, and we are closely monitoring performance and stability at this time. Further updates will be provided as needed.
Posted Mar 28, 2025 - 02:15 PDT

Update

Our teams have removed a backend component contributing to the issue and have temporarily isolated the services supporting automated access to vulnerability data. We are actively assessing the situation and working toward recovery. Further updates will be shared as progress continues.
Posted Mar 28, 2025 - 02:06 PDT

Investigating

Incident Description: We are currently investigating an issue affecting automated access to vulnerability data within the Software Vulnerability Research (SVR) platform. A subset of customers using integrations or scheduled processes to retrieve SVR data may be experiencing interruptions.

Note: This incident was initially classified as P2 during the early stages of investigation and troubleshooting, when the impact appeared to be limited to automated access only. As the situation progressed and broader platform instability was observed, including issues affecting the SVR web application - the priority was elevated to P1 to reflect the full scope of impact.

Priority: P1

Restoration Activity: Our technical teams have identified instability in the underlying API services that support automated access. Restoration efforts are underway, including isolating affected components and monitoring service behavior. Further updates will be provided as progress continues.
Posted Mar 28, 2025 - 01:25 PDT
This incident affected: Software Vulnerability Research.