Flexera One - Cloud Cost Optimization (CCO) - NAM - Degraded Policy Page Functionality

Incident Report for Flexera System Status Dashboard

Resolved

The incident began at 3:37 AM PDT when multiple production nodes became unhealthy. These nodes were replaced and infrastructure was scaled up as part of the remediation. Service was fully restored by 7:16 AM PDT.

The environment is now operational, and we will continue to monitor and investigate further to ensure ongoing stability.
Posted Oct 15, 2025 - 07:58 PDT

Investigating

Incident Description: We are currently investigating an issue within the Cloud Cost Optimization (CCO) platform impacting customers in the NAM region. The platform remains accessible; however, affected customers may experience degraded functionality on the Applied Policy Page, with certain tables not loading

Priority: P2

Restoration Activity: Our technical team is actively investigating the root cause and working to restore services as quickly as possible. We will continue to share updates as we make progress toward a resolution.
Posted Oct 15, 2025 - 05:11 PDT
This incident affected: Flexera One - Cloud Management - North America (Cloud Cost Optimization - US).