Saas Manager - NAM , EU & APAC - UI Loading Issue on Integrations Tab

Incident Report for Flexera System Status Dashboard

Postmortem

Description: SaaS Manager: Issue with the integrations tab in NA, EU, and APAC

Timeframe:  April 8th, 2025, 7:20 AM PST to April 8th, 2025, 1:33 PM

Incident Summary

On April 8th, 2025, at approximately 7:20 AM PST, our monitoring teams identified a User Interface issue affecting the Integrations tab for customers across all global regions — North America (NAM), Europe (EU), and Asia-Pacific (APAC). Affected users observed misaligned content and a non-functional "Setup" button under the Integrations tab.

The issue was determined to be UI-related, originating from a recent production release. A fix was developed and began rolling out shortly after identification, with an estimated deployment and validation window of 2–3 hours. Post all validations and customer confirmation, the issue was declared as resolved at 1:33 PM PST.

Root Cause

 

The issue was introduced as part of the production release deployed on April 6, 2025. While standard automation and regression tests were executed as part of the release process, limited test coverage existed for the affected Integrations tab . The page in question is part of an older legacy implementation and historically, the risk of regressions on legacy pages has been considered low. As a result, the regression affecting layout and button functionality went undetected during the release testing cycle, ultimately impacting users across all regions once the code was live in production. Plans are already in place to migrate these to a newer platform.

Remediation Actions

 

·        Engineering teams triaged and identified the UI regression on April 8.

·        A targeted fix was developed to address both the layout misalignment and the non-functional button.

·        The fix was deployed and validated across all affected environments within the same day, ensuring restored functionality.

Future Preventative Measures 

 

·        Accelerate Platform Migration : Expedite the planned migration of the page to a newer technology to leverage improved maintainability and higher automated test coverage.

·        Regression Test Audits: Conduct a comprehensive review of regression test cases to identify and close gaps related to legacy UI pages.

Posted Apr 16, 2025 - 00:48 PDT

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 21:47 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2025 - 13:46 PDT

Update

Our teams have identified an unexpected issue during the deployment. Investigation is underway, and we will provide further updates as progress is made.
Posted Apr 08, 2025 - 12:30 PDT

Identified

Our technical teams have developed a fix, which is currently in the process of being deployed. We will provide further updates as they become available.
Posted Apr 08, 2025 - 09:27 PDT

Investigating

Incident Description:
Our teams have identified a User Interface issue affecting customers in the NAM, EU, and APAC regions. Impacted users may observe misaligned or improperly displayed content under the Integrations tab.

Priority: P2

Restoration activity:
Our technical team is actively working on identifying the root cause and restoring services. Further updates will be provided as we continue our efforts to resolve the incident.
Posted Apr 08, 2025 - 07:28 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US SaaS Manager), Flexera One - IT Asset Management - APAC (IT Asset Management - APAC SaaS Manager), and Flexera One - IT Asset Management - Europe (IT Asset Management - EU SaaS Manager).