Data ingestion and export functionality for Snow Atlas in the Australia region has been restored.
Following further validation, we have confirmed there was no impact to the availability of the Snow Atlas application itself. Customers were able to access the application and view existing data throughout the incident. The impact was limited to data ingestion and export functionality following a scheduled maintenance window that extended beyond the planned downtime.
We will continue to monitor the service to ensure continued stability. A full post-mortem report containing a detailed incident summary, root cause, and future preventative measures will be shared in the coming days.
Posted Jun 02, 2026 - 09:18 PDT
Update
We are continuing to investigate the issue affecting Snow Atlas in the Australia region following the scheduled maintenance window that extended beyond the planned downtime. Initial reports indicated that Snow Atlas was unavailable; however, based on the latest update, customers can access the Snow Atlas application in the Australia region and view existing data.
At this time, customers may be unable to ingest new data or export data while remediation efforts continue. Ingestion and export requests are currently queuing and are expected to be processed once data ingestion is re-enabled. Our technical team is continuing work to restore full functionality, and we will provide further updates as progress is made.
Posted Jun 02, 2026 - 08:20 PDT
Investigating
Incident Description: We are currently investigating reports of Snow Atlas being inaccessible in the Australia region. The issue began following a scheduled maintenance window that extended beyond the planned downtime. Customers in the Australia region may be unable to access Snow Atlas at this time.
Priority: P2
Restoration Activity: Our technical team is actively working to restore access and remediate the issue. We are continuing to monitor progress closely and will provide further updates as remediation efforts continue.
Note: Following further validation, we have confirmed there was no impact to the availability of the Snow Atlas application itself. Customers were able to access the application and view existing data throughout the incident. The impact was limited to data ingestion and export functionality following the scheduled maintenance window extending beyond the planned downtime.
Posted Jun 02, 2026 - 07:46 PDT
This incident affected: Snow Atlas (Snow Atlas - Australia, Snow Atlas API - Australia).