Flexera One – IT Visibility – All Regions – Third-Party Inventory Import Processing Disruption

Incident Report for Flexera System Status Dashboard

Update

Our technical teams continue recovery efforts following the hotfix, and newly submitted inventory packages are progressing through processing as expected. Recovery work is currently focused on addressing missed messages from the affected period and validating the backfill approach for those items. As this work continues, some customers may still experience delays in processing.
Posted Apr 01, 2026 - 09:15 PDT

Update

Backlog processing continues to progress at a steady rate following the hotfix implementation. Our teams are actively monitoring the recovery to ensure complete resolution and system stability.
Posted Mar 31, 2026 - 23:58 PDT

Update

Our technical teams have identified the root cause and implemented a hotfix to restore normal data notification flow across the affected regions. Recovery activity is now focused on replaying missed notifications generated during the affected period. As this work continues, some customers may still experience residual delays and timeouts while backlog processing completes.
Posted Mar 31, 2026 - 15:39 PDT

Identified

Incident Description: We are currently investigating an issue affecting third-party inventory imports in Flexera One IT Visibility across all regions. As a result, some customers may experience delays in inventory processing and timeouts during imports.

Priority: P2

Restoration Activity: Our technical teams have identified the issue and are actively implementing mitigation steps to restore normal processing. Recovery actions are underway across the affected processing path. As processing resumes, some customers may continue to experience residual delays and timeouts while backlog processing is worked through.
Posted Mar 31, 2026 - 15:12 PDT
This incident affects: Flexera One - IT Visibility - North America (IT Visibility US), Flexera One - IT Visibility - Europe (IT Visibility EU), and Flexera One - IT Visibility - APAC (IT Visibility - APAC).