Flexera One- NAM- Login failing

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One- NAM- Login failing

Timeframe: December 4, 2025, 8:43 PM PST to December 4, 2025, 10:54 PM PST

Incident Summary

On Thursday, December 4, 2025, at 8:43 PM PST, the Flexera One platform encountered a service degradation in the North America (NAM) region, affecting login functionality. During this period, customers in the NAM region were unable to authenticate or access services, while the EU and APAC regions remained unaffected.

Upon detection of the issue, our technical teams promptly launched an investigation and identified that the issue stemmed from an unexpected surge in traffic coupled with a configuration issue that hindered service auto-scaling. To address the situation, the teams provisioned alternative infrastructure and executed recovery actions, successfully restoring service functionality. After conducting extended monitoring to ensure stability, full service was restored and confirmed as stable by 10:54 PM PST.

Root Cause

 

After a thorough investigation, our teams have determined that the issue stemmed from a combination of unexpectedly high traffic, inadequate processing capacity, and gaps in the configuration of workload placement controls. During peak load conditions, the system components responsible for managing requests were unable to scale efficiently, resulting in resource exhaustion and subsequent service instability.

Remediation Actions

 

To restore service, our teams performed below restorative actions:

  • Environment Stabilization- Migrated services to a newly provisioned, stable environment
  • Capacity Enhancement- Increased system capacity to handle elevated traffic levels
  • Scaling Optimization- Adjusted scaling thresholds to better accommodate demand

These actions successfully restored normal platform operations.

Future Preventative Measures

·        Improved Capacity Planning - Capacity planning processes are being strengthened to better align with traffic patterns.

·        Enhanced Monitoring and Alerting – Our teams are working to improve monitoring to detect early signs of system pressure.

·        Additional Stability Safeguards - Additional controls are to be implemented to ensure critical services remain stable during traffic surges.

Posted Jan 12, 2026 - 03:44 PST

Resolved

After extended monitoring, we have confirmed that the issue has been resolved and services remain stable.
Posted Dec 04, 2025 - 23:13 PST

Monitoring

As part of the restoration efforts, our teams provisioned alternative infrastructure, which has returned services to normal operation. We will continue to investigate the root cause and share further details in a post-mortem report.
Posted Dec 04, 2025 - 21:51 PST

Investigating

Issue Description: We are currently investigating a service degradation affecting the Flexera One platform in the North America region. Customers may experience issues accessing services at this time.

Priority: P1

Restoration Activity: Our technical teams have been engaged and are working to identify the affected service and determine the scope of impact. Further updates will be shared as the investigation progresses.
Posted Dec 04, 2025 - 21:02 PST
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US), Flexera One - Cloud License Management - North America (Cloud License Management - US), Flexera One - IT Asset Management - North America (IT Asset Management - US Login Page), and Flexera One - Cloud Management - North America (Cloud Cost Optimization - US).