Flexera One - IT Asset Management - NAM - Menu items not loading

Incident Report for Flexera System Status Dashboard

Resolved

Technical teams have confirmed that service has remained stable and affected IT Asset Management functionality is operating normally.

During the investigation, technical teams identified connection saturation conditions affecting application components responsible for user access and navigation functions. These conditions were observed during the impact window and coincided with the failures experienced by affected users.

Service functionality recovered, and customer validation confirmed that affected ITAM pages and menu items were loading successfully. Following a period of monitoring with no recurrence of the issue, the incident is now considered resolved.

A detailed review of the incident is ongoing to further validate contributing factors and identify any additional preventative actions.
Posted Sep 24, 2026 - 13:33 PDT

Monitoring

Technical teams are currently observing stable service behavior and a significant reduction in the errors associated with this incident. Affected application functions are operating normally based on current telemetry and monitoring data.

While service stability has improved, technical teams continue to monitor the environment closely to confirm that the issue does not recur. Investigation into the underlying cause remains ongoing.

We will continue monitoring and provide further updates as additional information becomes available.
Posted Sep 24, 2026 - 11:39 PDT

Update

Technical teams have made progress narrowing the scope of the issue and are focusing on the application components involved in loading user access and navigation information. Current findings indicate that some requests within this process are not completing as expected, resulting in menu items failing to load for affected users.

Work remains ongoing to determine the underlying cause and validate the appropriate remediation. Additional updates will be provided as more information becomes available.
Posted Sep 24, 2026 - 10:48 PDT

Update

Technical teams continue to investigate the issue affecting Flexera One IT Asset Management in the NAM Production environment.

Current efforts are focused on identifying where the failures are occurring within the affected workflow. Teams are reviewing application behavior, validation processes, service interactions, platform telemetry, and any recent changes or environmental conditions that may be contributing to the issue.

The investigation remains ongoing, and further updates will be provided as additional information becomes available.
Posted Sep 24, 2026 - 08:44 PDT

Investigating

Incident Description: We are investigating an issue affecting a subset of customers using Flexera One IT Asset Management (ITAM) in the NAM region. Affected customers may experience issues with navigation, including menu items not being visible in the ITAM interface, resulting in limited access to some functionality.

Priority: P2

Restoration Activity: Our technical teams are actively investigating this issue and working to restore full functionality. We will continue to provide updates as more information becomes available.
Posted Sep 24, 2026 - 07:08 PDT
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Business Reporting).