Flexera One- IT Asset management - EU - Inventory upload and Beacon communication issues

Incident Report for Flexera System Status Dashboard

Postmortem

Description: Flexera One- IT Asset management - EU - Inventory upload errors

Timeframe: July 31, 2026, 6:00 PM PDT to August 4, 2026, 4:09 AM PDT

Incident Summary

On Sunday, August 2, 2026, at 11:42 PM PDT, Flexera identified an issue affecting inventory package (*.zip) uploads and select beacon communications within the Flexera One IT Asset Management EU Production environment. Affected customers experienced failed inventory package uploads, including HTTP 504 (Gateway Timeout) and HTTP 405 (Method Not Allowed) responses. The issue also disrupted select beacon-to-platform communications, causing delays or failures in inventory processing and inventory data ingestion.

The investigation determined that earliest impact started at 6:00 PM PDT on July 31st , 2026. Analysis identified a communication issue within a critical service routing path that prevented a subset of requests from successfully reaching downstream processing services. This resulted in repeated retries, delayed inventory processing, and backlog accumulation.

To mitigate the issue and restore service, traffic was redirected to an alternate communication path. Following this change, beacon communications stabilized, inventory uploads resumed processing successfully, and the inventory backlog began to decrease. By 3:42 AM PDT on August 3, 2026, inventory uploads were completing successfully and no new errors were observed.

The environment remained under extended monitoring while processing volumes returned to normal operating levels. At 4:09 AM PDT on August 4, 2026, Flexera confirmed that beacon communications, inventory processing, and associated platform services were operating normally, the backlog had returned to expected thresholds, and the incident was formally declared resolved.

Root Cause

On 31 July 2026, a certificate update to a critical service communication path created a configuration mismatch between platform components. The issue surfaced later, when application components were restarted and began establishing new connections using the updated configuration. This caused handshake errors and communication failures, resulting in service unavailability. Consequently, requests from customer beacons to upload inventory package (*.zip) files to the EU Production environment could not be processed, causing upload failures and preventing inventory data from being received and processed. A subset of other beacon-to-platform interactions was also affected, although customer impact was not observed immediately.

Service was restored by redirecting traffic to an alternate communication path that was not affected by the certificate-related configuration issue. Inventory uploads and beacon communications then resumed normal operation.

Contributing Factors

  • Intermittent Request Failures: Failed connection establishment attempts caused a portion of requests to be unsuccessful before reaching downstream processing services.

  • Inventory Processing Delays: Communication failures prevented some inventory packages and associated imports from processing successfully, resulting in delayed inventory updates.

  • Retry-Driven Backlog Growth: Automated retry mechanisms enabled many transactions to eventually succeed but contributed to increased processing delays and backlog accumulation while the issue remained active.

Remediation Actions

To restore service, technical teams performed below actions:

  • Traffic Re-routing: Redirected traffic away from the affected service path to restore stable beacon communications and inventory package uploads.

  • Platform Monitoring: Performed continuous monitoring of beacon communications, inventory uploads, and processing activity to verify service recovery.

  • Backlog Recovery Management: Monitored inventory processing throughput and validated that processing backlogs steadily reduced and returned to expected operating thresholds.

  • Stability Validation: Conducted extended monitoring following restoration to confirm sustained platform stability and successful inventory processing.

  • Service Restoration Confirmation: At 4:09 AM PDT on August 4, 2026, confirmed that beacon communications, inventory processing, and associated services were operating normally.

Future Preventative Measures

  • Service Communication Resilience: Review and enhance the affected communication path to improve reliability, resiliency, and recovery from future connectivity-related disruptions.

  • Strengthened Change Validation: Enhance validation and testing processes for infrastructure, configuration, certificate, and service-path changes to identify communication mismatches before deployment into production environments.

  • Improved Detection and Alerting: Enhance monitoring and alerting capabilities to provide earlier identification of sustained communication disruptions, elevated retry activity, abnormal error-rate patterns, and emerging processing backlogs. These improvements will enable faster detection, investigation, and remediation of issues before they develop into broader customer impact.

Posted Aug 18, 2026 - 05:43 PDT

Resolved

The environment has returned to normal operating levels. Inventory processing and beacon communications are stable, and backlog has returned to expected thresholds.

The platform remains healthy, with continued monitoring confirming sustained stability. Additional details on the root cause, restorative actions, and long-term improvement initiatives will be shared in a post-mortem report following validation of the findings.
Posted Aug 04, 2026 - 04:09 PDT

Update

Service recovery remains on track, with mitigation measures continuing to be effective. Inventory processing is functioning successfully, and the backlog has been reduced significantly, bringing volumes closer to normal levels. Our teams continue to monitor the environment and process the remaining backlog to complete recovery. Further updates will be provided as appropriate.
Posted Aug 04, 2026 - 00:02 PDT

Update

Mitigation actions remain effective, and inventory processing is continuing successfully. We are actively monitoring recovery progress and working through the remaining backlog to ensure all processing is completed successfully. We will continue to provide updates as recovery efforts progress.
Posted Aug 03, 2026 - 10:09 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 03, 2026 - 03:40 PDT

Monitoring

Our teams have identified a recent configuration change as the likely cause of the issue. The configuration has since been rolled back, and we are observing service recovery across the affected components, with platform functionality gradually returning to expected levels. The teams remain actively engaged in monitoring the environment to validate full recovery, ensure platform stability, and quickly address any residual impacts.
Posted Aug 03, 2026 - 03:40 PDT

Update

During the ongoing investigation, our teams identified that the issue may also be impacting beacon communications with the Flexera One EU Production environment. As a result, additional operations that rely on beacon-to-platform communication may be affected. The team continues to investigate the underlying cause, assess the full scope of impact, and work towards implementing a resolution as quickly as possible.
Posted Aug 03, 2026 - 02:38 PDT

Update

Our teams continue to actively investigate the issue and are conducting a detailed review of system logs and diagnostics to further identify and confirm the underlying root cause. We will provide additional updates as more information becomes available.
Posted Aug 03, 2026 - 01:10 PDT

Investigating

Incident Description: We are currently investigating an issue affecting inventory package (*.zip) uploads in the Europe region for Flexera One IT Asset Management. Customers attempting to upload specific inventory packages may encounter errors, resulting in failed inventory uploads and delays in inventory data processing.

Priority: P2

Restoration Activity: Our technical team is actively investigating the issue and reviewing current processing activity to confirm scope and progress. We are monitoring the situation closely and will provide updates as more information becomes available.
Posted Aug 02, 2026 - 23:56 PDT
This incident affected: Flexera One - IT Asset Management - Europe (IT Asset Management - EU Beacon Communication, IT Asset Management - EU Inventory Upload).