All dashboards are now fully accessible across all regions, and our teams have confirmed normal operation.
The issue was caused by an internal service responsible for managing dashboard authentication not functioning as expected, which led to temporary loss of access across regions. The service has been corrected, and access has been fully restored.
A full retrospective will be conducted in the coming days to review the incident and implement long-term preventive measures.
Posted Nov 04, 2025 - 16:13 PST
Monitoring
Dashboards are now accessible in EU, and all regions (NAM, EU, and APAC) are restored. Our teams are monitoring the environment to ensure continued stability and will close this incident once verification is complete.
Posted Nov 04, 2025 - 15:24 PST
Identified
Dashboards in NAM and APAC are now stable and fully accessible following recovery efforts. Work continues to restore access in EU, where dashboards may remain unavailable. Our teams are monitoring progress closely and will provide another update once recovery in EU is confirmed.
Posted Nov 04, 2025 - 14:48 PST
Update
Analysis of the reporting components and data connections is ongoing to pinpoint the source of the disruption. Some improvement has been observed, though access remains limited in certain regions. Work toward full restoration continues, and we will provide further updates as more information becomes available.
Posted Nov 04, 2025 - 14:05 PST
Update
Our technical teams are performing detailed analysis of the reporting layer and related data connections to identify the cause of the disruption. We are actively working toward restoration and will provide further updates as progress continues.
Posted Nov 04, 2025 - 12:56 PST
Investigating
Incident Description: We are currently investigating an issue affecting Flexera One – IT Visibility (ITV) and Cloud License Management (CLM) dashboards. Customers across all regions may experience errors or inability to access dashboards and reports.
Priority: P1
Restoration Activity: Our technical teams are actively investigating the issue to determine the cause and restore functionality as soon as possible. Further updates will be provided as more information becomes available.
Posted Nov 04, 2025 - 12:49 PST
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US), Flexera One - IT Visibility - Europe (IT Visibility EU), Flexera One - IT Visibility - APAC (IT Visibility - APAC), Flexera One - Cloud License Management - North America (Cloud License Management - US), Flexera One - Cloud License Management - Europe (Cloud License Management - EU), and Flexera One - Cloud License Management - APAC (Cloud License Management - APAC).