Flexera One – IT Visibility – NA – Data Explorer Request Failures

Incident Report for Flexera System Status Dashboard

Resolved

Rollback actions have been completed successfully, and Data Explorer functionality has been restored in the NA region. Our investigation determined the issue was related to a service-side deployment/configuration problem affecting request processing. Service has been validated following mitigation, and requests are now completing as expected. We will complete a full root cause analysis with the teams involved and provide a post-mortem report outlining the underlying cause and preventive measures identified.
Posted Mar 31, 2026 - 14:38 PDT

Identified

Our technical teams have identified a potential cause and are actively implementing mitigation steps to restore Data Explorer functionality in the NA region. Current investigation indicates the failure is related to a service-side issue affecting request processing, and rollback actions are currently in progress. We are monitoring the outcome of these changes closely and will provide a further update as soon as more information becomes available.
Posted Mar 31, 2026 - 13:53 PDT

Investigating

Incident Description: We are investigating an issue affecting Data Explorer within Flexera One IT Visibility in the NA region. Customers may encounter errors when using Data Explorer, and requests may fail to return results as expected.

Priority:
P2

Restoration Activity: Our technical teams are actively investigating the issue and working to restore normal functionality. We are closely monitoring progress and will provide further updates as they become available.
Posted Mar 31, 2026 - 13:08 PDT
This incident affected: Flexera One - IT Visibility - North America (IT Visibility US).