FlexNet Manager Suite Cloud - EU - Some customer Licensing compliance positions may be incomplete
Incident Report for Flexera System Status Dashboard
Postmortem

Description: A small number of customers on EU Group 1 may have had incomplete licensing positions as a result of some inventory uploads completing with errors.

Timeframe: February 25th 2:30 AM to February 25th 12:30 PM CET

Incident Summary

On Tuesday the 25th customers reported that their inventory imports were failing. Investigations revealed that the inventory job numbers were exceeding 32 Bit numbers causing the importer to fail. While the database was able to work with 64 Bit inventory job numbers the Importer had not yet been upgraded with 64 Bit support.

Support teams added additional disk space to the database cluster and reseeded the database to bring the import job numbers back within the 32-Bit Importer job number limit, restoring services.

Root Cause

This incident was a result of a communications breakdown between several teams. While the 32-Bit application limitation was understood, relevant personal were not advised that the upgrade to the application, enabling 64-Bit integer support, was not going to be included in Release 2.1 and had been deferred to Release 2.3. As a result, additional monitoring and re-seeding of the database was thought to unnecessary.

Corrective Action

Problem Management will ensure all relevant teams are made aware of changes to Releases/Upgrades which are likely to negatively impact production applications.

Posted Mar 23, 2020 - 20:36 PDT

Resolved
The hotfix has been successfully deployed to the production environment. Health checks and monitoring have confirmed services are operating normally.
Posted Feb 25, 2020 - 03:41 PST
Update
The Hotfix Implementation is currently proceeding as planned and is expected to be complete within the next 2 hours.

Next Update: Tuesday, February 25 @ 13:30 pm CET
Posted Feb 25, 2020 - 02:33 PST
Update
We are currently implementing a hotfix to restore services. This process may take up to 4 hours to complete.

Next Update: Tuesday, February 25 @ 11:30 am CET
Posted Feb 25, 2020 - 00:30 PST
Identified
Incident Description:
A small number of customers, on EU Group 1, may have incomplete licensing positions as a result of some inventory uploads completing with errors.

Priority: 2

Restoration activity:
A Hotfix is currently being applied to resolve this issue.

Next Update: Tuesday, February 25 @ 9:30 am CET
Posted Feb 24, 2020 - 22:48 PST
This incident affected: Flexera One - IT Asset Management - Europe (IT Asset Management - EU Inventory Upload).