Flexera One – IT Asset Management – NA – Inventory Uploads Not Processing

Incident Report for Flexera System Status Dashboard

Resolved

Inventory upload processing in the North America region has been fully restored. All services are operating normally, and processing is back to expected levels.

This incident is now resolved.
Posted Nov 25, 2025 - 12:26 PST

Monitoring

Our technical team has confirmed that the issue began after last night’s release and was caused by a configuration problem affecting inventory upload processing in the North America region. This configuration has now been corrected, and authentication and inventory data uploads are beginning to flow normally. We are monitoring closely to ensure processing remains stable and that any backlog continues to clear.
Posted Nov 25, 2025 - 09:28 PST

Investigating

Incident Description: We are investigating an issue impacting inventory data uploads for IT Asset Management (ITAM) in the North America region. Affected customers may experience upload failures, timeouts, or delays as inventory files are not currently reaching the processing service.

Priority: P1

Restoration Activity: Our technical teams are actively investigating the cause and working to restore normal upload processing. We are monitoring the environment closely and will continue to share updates as progress is made toward full restoration.
Posted Nov 25, 2025 - 08:22 PST
This incident affected: Flexera One - IT Asset Management - North America (IT Asset Management - US Inventory Upload).